1、路由反射器解析
成都創(chuàng)新互聯(lián)專注于三門峽網(wǎng)站建設(shè)服務(wù)及定制,我們擁有豐富的企業(yè)做網(wǎng)站經(jīng)驗(yàn)。 熱誠(chéng)為您提供三門峽營(yíng)銷型網(wǎng)站建設(shè),三門峽網(wǎng)站制作、三門峽網(wǎng)頁(yè)設(shè)計(jì)、三門峽網(wǎng)站官網(wǎng)定制、成都小程序開發(fā)服務(wù),打造三門峽網(wǎng)絡(luò)公司原創(chuàng)品牌,更為您提供三門峽網(wǎng)站排名全網(wǎng)營(yíng)銷落地服務(wù)。
路由反射器工作原理:
RR從EBGP收到的路由,會(huì)反射給客戶端和非客戶端
RR從客戶端收到的路由,會(huì)反射給客戶端、EBGP鄰居和非客戶端
RR從非客戶端收到的路由,只會(huì)反射給客戶端和EBGP鄰居,不會(huì)反射給非客戶端
2、實(shí)驗(yàn)拓?fù)?/p>
3、基礎(chǔ)配置
R1配置
interface Loopback0
ip address 1.1.1.1 255.255.255.0
interface Serial0/0
ip address 12.1.1.1 255.255.255.0
router bgp 1
no synchronization
bgp router-id 1.1.1.1
network 1.1.1.0 mask 255.255.255.0
neighbor 12.1.1.2 remote-as 2
no auto-summary
R2配置
interface Loopback0
ip address 2.2.2.2 255.255.255.0
interface Serial0/0
ip address 12.1.1.2 255.255.255.0
interface Serial0/1
ip address 23.1.1.2 255.255.255.0
router ospf 110
router-id 2.2.2.2
network 2.2.2.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
router bgp 2
no synchronization
bgp router-id 2.2.2.2
neighbor 3.3.3.3 remote-as 2
neighbor 3.3.3.3 update-source Loopback0
neighbor 3.3.3.3 next-hop-self
neighbor 12.1.1.1 remote-as 1
no auto-summary
R3配置
interface Loopback0
ip address 3.3.3.3 255.255.255.0
interface Serial0/0
ip address 34.1.1.3 255.255.255.0
interface Serial0/1
ip address 23.1.1.3 255.255.255.0
router ospf 110
router-id 3.3.3.3
network 3.3.3.0 0.0.0.255 area 0
network 23.1.1.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
router bgp 2
no synchronization
bgp router-id 3.3.3.3
neighbor 2.2.2.2 remote-as 2
neighbor 2.2.2.2 update-source Loopback0
neighbor 4.4.4.4 remote-as 2
neighbor 4.4.4.4 update-source Loopback0
no auto-summary
R4配置
interface Loopback0
ip address 4.4.4.4 255.255.255.0
interface Serial0/0
ip address 34.1.1.4 255.255.255.0
router ospf 110
router-id 4.4.4.4
network 4.4.4.0 0.0.0.255 area 0
network 34.1.1.0 0.0.0.255 area 0
router bgp 2
no synchronization
bgp router-id 4.4.4.4
neighbor 3.3.3.3 remote-as 2
neighbor 3.3.3.3 update-source Loopback0
no auto-summary
4、水平分割導(dǎo)致的問(wèn)題
5、配置路由反射器解決水平分割
R3配置
router bgp 2
neighbor 2.2.2.2 route-reflector-client
neighbor 4.4.4.4 route-reflector-client